Vous êtes ici

Quelle est la version PHP minimale nécessaire pour faire tourner Drupal 8 ?

Portrait de DrupalFacile
Soumis par DrupalFacile le sam, 17/10/2015 - 15:40

Drupal 8 requiert désormais PHP 5.5.9 - Notez néanmoins que le support actif de PHP 5.5 est terminé et qu'à partir de juillet 2016 il n'y aura plus non plus de patches de sécurité. Si vous en avez la possibilité, n'attendez pas et passez de suite à PHP 5.6. C'est d'ailleurs ce que la communauté essaye de promouvoir en voulant afficher une alerte dans l'administration des sites qui utilisent encore PHP 5.5. Encore une note, depuis PHP 5.6.5 (et 5.5.21) PHP fournit également une protection native aux injections SQL, raison de plus pour ne pas utiliser la version minimale requise.

Du point de vue des performances, PHP 7 changera grandement la donne (voir les benchmarks de Rasmus Lerdorf, créateur de PHP). L'issue Drupal pour suivre la compatibilité de Drupal 8 avec PHP 7 est visible ici.

Vous pouvez voir tous les détails des prérequis dans le fichier core/INSTALL.txt (voir sur drupal.org)

Version: 
Drupal 8
Niveau: 
Débutant

Tags:

Partager ce contenu