Vous êtes ici

LAMP

Quelles sont les extensions PHP requises pour faire tourner Drupal 8 ?

Portrait de DrupalFacile
Soumis par DrupalFacile le dim, 25/10/2015 - 09:10

Lorsque Drupal est en cours d'installation, plusieurs modules sont activés par défaut, selon le profil d'installation que vous choisissez. Un module crucial duquel Drupal dépend est le module system, qui, comme son nom l'indique, est nécessaire au bon fonctionnement du 'système' de Drupal. Ce module utilise un fichier system.install pour notamment faire une vérification de dépendances des extensions PHP comme indiqué ci-dessous. Extrait :

Tags:

Partager ce contenu

Comment avoir accès à la configuration complète de PHP sous Drupal 8 ?

Portrait de DrupalFacile
Soumis par DrupalFacile le sam, 24/10/2015 - 10:00

Ce n'est pas nouveau sous Drupal 8, mais toujours quelque chose de bon à savoir si cela vous a échappé. En vous rendant sur le Tableau de bord d'administration (/admin/reports/status), vous pouvez obtenir toutes les informations relatives à votre configuration courante de PHP. La section qui vous intéresse est PHP suivi de la version exacte de PHP qui propulse Drupal.

Partager ce contenu

Quelle sont les versions SQL minimales nécessaires pour faire tourner Drupal 8 ?

Portrait de DrupalFacile
Soumis par DrupalFacile le dim, 18/10/2015 - 10:37

La version MySQL minimale nécessaire pour faire tourner Drupal 8 est la 5.5.3 - Notez que MySQL 5.6 existe est serait préférable si jamais vous avez la possibilité de l'utiliser. Drupal 8 est pleinement compatible avec. MySQL 5.7 existe aussi mais il y a quelques incompatibilités connues (notamment avec le mode ANSI SQL) qui donnent envie d'attendre.

Tags:

Partager ce contenu

Quelle est la version PHP minimale nécessaire pour faire tourner Drupal 8 ?

Portrait de DrupalFacile
Soumis par DrupalFacile le sam, 17/10/2015 - 15:40

Drupal 8 requiert désormais PHP 5.5.9 - Notez néanmoins que le support actif de PHP 5.5 est terminé et qu'à partir de juillet 2016 il n'y aura plus non plus de patches de sécurité. Si vous en avez la possibilité, n'attendez pas et passez de suite à PHP 5.6. C'est d'ailleurs ce que la communauté essaye de promouvoir en voulant afficher une alerte dans l'administration des sites qui utilisent encore PHP 5.5.

Tags:

Partager ce contenu

Bug PHP Suhosin avec la barre de progression PECL

Portrait de DrupalFacile
Soumis par DrupalFacile le ven, 02/11/2012 - 08:43

Lorsque vous ajoutez par exemple un champ Fichier dans un type de contenu afin de joindre un document, vous avez la possibilité de sélectionner soit le "throbber", soit la fameuse barre de progression PECL. Elle n'a d'intérêt que pour les envois de fichiers qui peuvent prendre plus que quelques secondes à envoyer, afin d'optimiser l'expérience de l'éditeur qui a évidemment besoin de savoir combien il devra encore attendre pour que l'envoi soit terminé.

Tags:

Partager ce contenu

Episode 33 - Installer Drupal 7 avec Acquia Drupal Stack Installer

Portrait de DrupalFacile
Soumis par DrupalFacile le lun, 24/01/2011 - 08:07

Découvrez comment installer facilement et rapidement Drupal 7 en local sur Windows, Linux ou Mac à partir de Acquia Drupal Stack Installer, la pile d'outils pré-packagés d'Acquia (Drupal, Apache, MySQL et PHP) pour vous concentrer sur la création de votre site plutôt que sur la configuration technique de votre environnement de développement.

Partager ce contenu
S'abonner à RSS - LAMP